jejmule
Topic Author
Posts: 1
Joined: 11 May 2021, 12:44

Question about DIO output

11 May 2021, 12:59

Hello,

I am working on a project where I control two frequency inverters Mitsubshi FR-D700 and Hitachi WJ200. I have attached input description of both inverter, both inverter are configured with sourcings inputs.
I have a 24v external power supply connected on X2 connector. I am using O1 and O2 to drive FR-D700 inverter and O3 and O4 to drive WJ200 inverter. power supply GND is connected to pin SD and L of inverter (internal GND).

When the output are configured in High-side mode i have the following behavior : when I am driving WJ200 inverter I have also a current flowing into FR-D700 even if there related output are low.
The issue is solved if I am using push-pull mode.

Can you explain me why I have this behavior? Why current is flowing in O3-O4 when they are in high impedance state while O1 or O2 is in high state.

Let me know if my problem is clear or not, I can make a schematic connection diagram if required
Attachments
FR-D700-input.PNG
FR-D700-input.PNG (41.72 KiB) Viewed 682 times
WJ200-input.PNG
WJ200-input.PNG (22.09 KiB) Viewed 682 times
 
User avatar
dirk
KUNBUS
Posts: 1570
Joined: 15 Dec 2016, 13:19

Re: Question about DIO output

04 Jun 2021, 10:39

Hi jejmule,
Thank you very much for your detailed error report.
Please check the wiring. You could also install coupling relays between the DIO outputs and inverter inputs.

Who is online

Users browsing this forum: No registered users and 8 guests