francescoizzi
Topic Author
Posts: 18
Joined: 17 Feb 2018, 12:10

Modbus timing and timeouts

14 Feb 2019, 09:38

Hi all,

i try to configure a revolutionPi3 to read RS485 High performance soil and subtrates moisture sensor but without success.

I configured the modbus rtu master in pictory as usual ... image below ...
Schermata 2019-02-14 alle 09.18.20.png
Schermata 2019-02-14 alle 09.18.20.png (334.54 KiB) Viewed 1281 times
the piTest always fail with 110 error:

piTest -r Modbus_Action_Status_1
1 Byte-Value of Modbus_Action_Status_1: 110 dez (=6e hex)
1 Byte-Value of Modbus_Action_Status_1: 110 dez (=6e hex)
1 Byte-Value of Modbus_Action_Status_1: 110 dez (=6e hex)
1 Byte-Value of Modbus_Action_Status_1: 110 dez (=6e hex)
1 Byte-Value of Modbus_Action_Status_1: 110 dez (=6e hex)

The strange thing is that with QmodBus installed on Raspberry i successful connect and read register... image below...
Schermata 2019-02-14 alle 09.34.59.jpg
Schermata 2019-02-14 alle 09.34.59.jpg (449.94 KiB) Viewed 1281 times
The register 15 is the sensor board temperature ... the read value is correct

Any suggestion ?
 
User avatar
zhan
KUNBUS
Posts: 8
Joined: 16 Apr 2019, 13:31

Re: Modbus timing and timeouts

16 May 2019, 15:10

hi francescoizzi,

sorry for replying late.

https://revolution.kunbus.com/tutorials ... rect=en_US
in this document, the 110 is described as "CONNECTION TIMED OUT The slave did not respond fast enough or not at all. Check your configuration and wiring."
Maybe in your case it is just not fast enough, is it possible?

thanks.
Simon
Simon

Who is online

Users browsing this forum: No registered users and 4 guests