dhicks
Topic Author
Posts: 2
Joined: 30 May 2019, 12:53

Unable to run latest runtime version

30 May 2019, 12:56

I’m trying to obtain a CID file for a runtime license but the latest version of proton-web-iot won’t run on my RevPi. I’ve updated to the latest jessie version.
pi@RevPi100102:~/procon-web-iot $ cat /etc/revpi/image-release
../2017-09-22-revpi-jessie.img

Following the quick start guide I performed apt-get update and apt-get install pictory. I enable proton-web-iot from the service page of web status. In the procon designer(version 6.3.7) no systems are listed in the runtime target screen. Starting the service from the command line I get the following:
pi@RevPi100102:~/procon-web-iot $ sudo systemctl -l status procon-web-iot
● procon-web-iot.service - PROCON-WEB HMI runtime system
Loaded: loaded (/lib/systemd/system/procon-web-iot.service; enabled)
Active: failed (Result: exit-code) since Thu 2019-05-30 01:36:12 CEST; 54s ago
Docs: https://www.gti.de/produkte-der-gti/procon-web/
Process: 3712 ExecStart=/usr/lib/procon-web-iot/procon-web-iot (code=exited, status=132)
Main PID: 3712 (code=exited, status=132)

May 30 01:36:10 RevPi100102 systemd[1]: Started PROCON-WEB HMI runtime system.
May 30 01:36:11 RevPi100102 procon-web-iot[3712]: /usr/lib/procon-web-iot/procon-web-iot: line 5: 3716 Illegal instruction LD_PRELOAD=$SCRIPTPATH/libstdc++.so.6.0.25 $SCRIPTPATH/node/node $SCRIPTPATH/dist/src/app.js
May 30 01:36:12 RevPi100102 systemd[1]: procon-web-iot.service: main process exited, code=exited, status=132/n/a
May 30 01:36:12 RevPi100102 systemd[1]: Unit procon-web-iot.service entered failed state.

I am able to run the 1.2.1 version.


procon-web-iot:
Installed: 6.3.7.0-1
Candidate: 6.3.7.0-1
Version table:
*** 6.3.7.0-1 0
500 http://packages.revolutionpi.de/ jessie/main armhf Packages
100 /var/lib/dpkg/status
1.2.1-1 0
500 http://packages.revolutionpi.de/ jessie/main armhf Packages
 
User avatar
dirk
KUNBUS
Posts: 396
Joined: 15 Dec 2016, 13:19

Re: Unable to run latest runtime version

31 May 2019, 07:59

Dear dhicks, please update to the latest Stretch (03/2019) version as there have been a lot improvements since Jessie
It is compatible with all the RevPi Core 1,3 and Connect modules, see here:
https://revolution.kunbus.com/tutorials ... rect=en_US
You may donwload it for free on the shop
https://revolution.kunbus.de/shop/en/stretch

Maybe then the Procon errors will be fixed...
 
dhicks
Topic Author
Posts: 2
Joined: 30 May 2019, 12:53

Re: Unable to run latest runtime version

31 May 2019, 17:54

I updated to stretch but still get the same error.

pi@RevPi100102:/usr/lib/procon-web-iot $ sudo systemctl -l status procon-web-iot
● procon-web-iot.service - PROCON-WEB HMI runtime system
Loaded: loaded (/lib/systemd/system/procon-web-iot.service; enabled)
Active: failed (Result: exit-code) since Fri 2019-05-31 00:46:11 CEST; 46s ago
Docs: https://www.gti.de/produkte-der-gti/procon-web/
Process: 1413 ExecStart=/usr/lib/procon-web-iot/procon-web-iot (code=exited, status=132)
Main PID: 1413 (code=exited, status=132)

May 31 00:46:10 RevPi100102 systemd[1]: Started PROCON-WEB HMI runtime system.
May 31 00:46:11 RevPi100102 procon-web-iot[1413]: /usr/lib/procon-web-iot/procon-web-iot: line 6: 1420 Illegal instruction LD_PRELOAD=$SCRIPTPATH/libstdc++.so.6.0.25 $SCRIPTPATH/node $SCRIPTPATH/dist/src/app.js
May 31 00:46:11 RevPi100102 systemd[1]: procon-web-iot.service: main process exited, code=exited, status=132/n/a
May 31 00:46:11 RevPi100102 systemd[1]: Unit procon-web-iot.service entered failed state.

After some searching it seems this happens because architecture(armv6) isn't detected and armv7 instructions are used. I installed and used node-v11.6.0-linux-armv6l and a nd libstdc++.so.6.0.20 and procon runs but with errors because of missing library objects. libstdc++.so.6.0.25 still generates 'illegal instruction'
sudo systemctl -l status procon-web-iot
● procon-web-iot.service - PROCON-WEB HMI runtime system
Loaded: loaded (/lib/systemd/system/procon-web-iot.service; enabled)
Active: active (running) since Fri 2019-05-31 00:13:03 CEST; 6s ago
Docs: https://www.gti.de/produkte-der-gti/procon-web/
Main PID: 1025 (procon-web-iot)
CGroup: /system.slice/procon-web-iot.service
├─1025 /bin/bash /usr/lib/procon-web-iot/procon-web-iot
└─1032 /usr/lib/procon-web-iot/node /usr/lib/procon-web-iot/dist/src/app.js
error: Couldn't load service: connector-webserver Error: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6.0.20: version `CXXABI_1.3.9' not found (required by /usr/lib/procon-web-iot/node_modules/@gti/basic-fnc/basicFnc.node)

Who is online

Users browsing this forum: No registered users and 1 guest